Skip to content

Change font size

Atwood Range ?

Generalized RV discussion not covered in another forum - the "Catch All" for RV talk!

Moderator: Zinger

Forum rules
Although RV-forums.org is an easy-going place, we do have a few easy to follow rules. Please read up on them here.

Atwood Range ?

Unread postby tvman44 on Sun Dec 14, 2014 10:20 am

We have a Atwood MPD57279 & 1 top burner will not light with the ignitor, it seems to spark as good as the other 2 top burners but will not light. I can light that burner with a match and get as high & good a flame as the other 2 that light with the igniter. I have tried cleaning the electrode anyway but no joy. Anyone have have a similar problem, or have any good suggestions?
Papa Bob
1* DW "Granny"
1* 2008 Brookside Sunnybrook 32'
1* 2002 F250 Super Duty 7.3L PSD
Firestone Ride Rite Air Springs, Trailair Equa-Flex, Champion C46540
"A bad day camping is better than a good day at work!"
User avatar
tvman44
Member
Member
 
Posts: 27
Joined: Thu Dec 18, 2008 12:15 pm

Re: Atwood Range ?

Unread postby RonJK on Sun Dec 14, 2014 7:54 pm

TVman44

It is possible that the gap between the ignitor and the burner is wrong.

It may be positioned a bit too close or too high as propane is heavier than air.

Try adjusting the gap and see what happens.

If the electrode is sparking at the burner and you have propane that should be the issue.

Good luck.
User avatar
RonJK
Site Admin
Site Admin
 
Posts: 334
Joined: Wed Dec 21, 2011 5:46 pm
Location: British Columbia


Return to General RV Discussion

Who is online

Users browsing this forum: Bing [Bot] and 2 guests

Up Login   Register Up
cron