Skip to content

Change font size

HVAC on 94 Prowler 30' no power

Heating, Ventilation & Air Conditioning Q&A

HVAC on 94 Prowler 30' no power

Unread postby Mikey on Sat Aug 16, 2008 7:44 pm

Hi guys,

I've got a friend who has a 94 prowler 5Wheel. No AC, or Heat. I checked the thermostat and there is no power coming through the RhRc wire, so crossing the Y and W to the Rh/Rc directly doesn't produce a result.

The AC breaker has power.

I don't know where the power goes from the breaker to the thermostat. It has to go to a transformer to get from 115 to 24vac. Does anyone have a wiring diagram and perhaps know where to find the transformer?

Or has any other hints?
2008 Amerilite 23bw
Towed by a Silverado 2500 HD.
Other toys:CBR1100XX,EX500 ImageImage

Speed doesn't kill. Your wife finding out you got a ticket, does.
Mikey
Established Member
Established Member
 
Posts: 94
Joined: Fri Mar 14, 2008 10:19 am
Location: Hamilton, Ontaro

Re: HVAC on 94 Prowler 30' no power

Unread postby hilldude on Wed Oct 22, 2008 9:52 am

Do you have 12v, camper furnace operates on 12v.
User avatar
hilldude
Member
Member
 
Posts: 34
Joined: Fri Mar 14, 2008 11:50 am
Location: Red House WV

Re: HVAC on 94 Prowler 30' no power

Unread postby cwit on Wed Oct 22, 2008 2:33 pm

Your thermostat wires go from furnace to thermostat. Check for 12 volts.
User avatar
cwit
Senior Member
Senior Member
 
Posts: 439
Joined: Wed Apr 09, 2008 6:48 am
Location: Lake Champlain, NY

Re: HVAC on 94 Prowler 30' no power

Unread postby Zinger on Wed Oct 22, 2008 6:13 pm

try jumping out the thermostat terminals on the furnace if it runs possibly a break in a wire you can twist togather on one end and test with a continuity tester at other end also if jumping the tt doesnt work check and make sure you have 12v at furnace.
Have a good one
Greg Morin
2008 Zinger ZT 260 BH

Image
User avatar
Zinger
Senior Contributor
Senior Contributor
 
Posts: 761
Joined: Thu Mar 13, 2008 7:37 pm
Location: Buskirk NY

Re: HVAC on 94 Prowler 30' no power

Unread postby Mikey on Sun Oct 26, 2008 9:20 am

Ok, it wasn't my furnace but I did what everyone suggested.

1) no 12 volts...therefore...
2) didn't work when jumped.

I took 12 volts right off the breaker panel with a long wire and applied power to the thermostat. The system worked. Therefore we had a power break, I just have to figure out how to re-run another line.
2008 Amerilite 23bw
Towed by a Silverado 2500 HD.
Other toys:CBR1100XX,EX500 ImageImage

Speed doesn't kill. Your wife finding out you got a ticket, does.
Mikey
Established Member
Established Member
 
Posts: 94
Joined: Fri Mar 14, 2008 10:19 am
Location: Hamilton, Ontaro

Re: HVAC on 94 Prowler 30' no power

Unread postby Zinger on Sun Oct 26, 2008 7:37 pm

Are you sure its not just a blown fuse inthe converter charger near the breakers?
Have a good one
Greg Morin
2008 Zinger ZT 260 BH

Image
User avatar
Zinger
Senior Contributor
Senior Contributor
 
Posts: 761
Joined: Thu Mar 13, 2008 7:37 pm
Location: Buskirk NY


Return to HVAC

Who is online

Users browsing this forum: No registered users and 1 guest

Up Login   Register Up
cron